Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 05, 2026 - 14:00 UTC
Scheduled
The GIDR.ai Platform will be undergoing scheduled maintenance for Release 26.49.001 on Mar 5, 2026, from 16:00 UTC to 17:00 UTC. During this time, some services may be temporarily unavailable.
Sprint 49 Release Highlights
🚀 UI Improvements & Minor Updates – GA • AI Platform – BYOLLM: Added Anthropic and Gemini models to BYOLLM options. • Analytics: Enhanced Organization and Team Analytics to show usage metrics, including number of Sessions and Interactions consumed. • AI Platform: Deprecated Gemini 3 Pro Preview. • Voice: Updated default ElevenLabs voice from Turbo to V3.
🐞 Bug Fixes & Platform Improvements • Video Instructions / Video Explanation: Fixed multiple issues including cancel button behavior, enter key error messaging, formatting persistence, and play button failures in specific scenarios. • Teams & Admin UI: Fixed team name rendering when the name starts with “Team”, incorrect user display in team access settings, and duplicate team display issues. • Voice ReAct / Flows: Fixed issue preventing import of flows containing the Voice ReAct node in certain scenarios. • MCP Server: Fixed mismatch in “Active” status display between English and Japanese. • Design View: Fixed intermittent issue where resizing a Gidget did not apply reliably. • Org Settings Visibility: Fixed issue where organization settings could appear on the wrong user’s screen. • AI / API: Resolved OpenAI-compatible API internal server error. • Multimodal / Audio: Addressed audio chunk splitting specification handling. • Insight: Fixed issue preventing SVG upload for avatar. • Invitations: Fixed UI issue showing a gray area when inviting a member to a GIDR.
Posted Mar 05, 2026 - 00:58 UTC
This scheduled maintenance affected: GIDR.ai Portal, GIDRs & Gidgets, and GIDR.ai APIs.